Atheros ar5001 and Ubuntu 10.04 Lucid

I got my hands asus eeepc 1000hg. Of course, first of all, it has been installed Ubuntu 10.04 (do not kick, he meant not the laptop for my use). All iron worked fine, except wi-fi module, which turned out to be a chip ar5001 from the company Atheros. Or rather – AR5001 Wireless Network Adapter

What is a problem is expressed. First of all that is lost permanently conjoined with any wifi network.

The first council was encountered in the network board installed wireless-lucid-backports (the exact name of the package can not remember). And several backports packages. In no case do not do it. The stability of the connection is not affected, but the connection speed is reduced significantly. I have these packets speed dropped to about 400 bytes per second. Yes, it is a byte. If you put the packages * -backports- * on the advice of the forum on a bourgeois – delete them right away.

Actually wifi module is now working fine. The solution was to upgrade the kernel to 2.6.33. Here is the problem in a single command, even greater. Knowledgeable – will understand what makes this team, ignorant – just enter this command and reboot.

inky @ eeepc: ~ $ mkdir kernel && cd kernel / && wget && Wget && Wget && Sudo dpkg -i linux-headers-2.6.33-020633_2.6.33-020633_all.deb && sudo dpkg -i linux-headers-2.6.33-020633-generic_2.6.33-020633_i386.deb && sudo dpkg -i linux-image -2.6.33-020633-generic_2.6.33-020633_i386.deb && sudo update-grub && cd .. && rm -r kernel /

Everything. When you boot you should automatically zagruuzitsya new kernel (if it does not happen – select it from the menu Grub, and then correct grub.conf). Ar5001 now works in your Ubuntu 10.04. Without any glitches and bugs.

P.S. – Those who think that this is a problem Ubuntu – try to put the driver on ar5001 in Piggy SP2;)